User Tools

Site Tools


teaching:corrections13

Corrections exercice 13

Janvier

A1

Format: Standard
Formule: =$Annuelle.$F$1

D1

Format: Date (MMMM AA)
Formule: =DATE(ANNEE($Annuelle.$F$2),FEUILLE(),1)

B4

Format: standard
Formule: =SI(MOIS($D$1)=1,CONCATENER("Solde ",ANNEE($D$1)-1),CONCATENER("Solde ",TEXTE(DATE(ANNEE($D$1),MOIS($D$1)-1,1),"MMMM AAAA")))

G4

Format: standard
Formule: =SI(FEUILLE()>1,INDIRECT(ADRESSE(LIGNE(G38),COLONNE(G38), , ,TEXTE(DATE(ANNEE(D$1),MOIS(D$1)-1,1),"MMMM"))),"")

ou

Format: standard
Formule: =SI(FEUILLE()>1,INDIRECT(ADRESSE(LIGNE(G38),COLONNE(G38), 1, ,NOMFEUILLE(FEUILLE()-1))),"")

avec la macro

REM  *****  BASIC  *****
'Fonction NomFeuille
'Auteur : Jeff & Larrassac
'Mes remerciements au forum officiel OOo : http://user.services.openoffice.org/fr/forum/index.php
'Mes remerciements au Club des développeurs français : http://www.developpez.net/forums/
 
Function NomFeuille(position as integer)
Dim oDoc As Object
On error goto Erreurs 'contrôle si le numéro de feuille existe
 
oDoc=ThisComponent
 
     NomFeuille = oDoc.Sheets(position-1).Name
 
Erreurs: 'Retourne #NA si le numéro de feuille est inexistant
   if position < 1 or position > oDoc.Sheets.count then
      NomFeuille = "#NA"
      Exit Function
   Endif
 
End Function

http://user.services.openoffice.org/fr/forum/viewtopic.php?f=8&t=11717&start=0

Ligne 5

Formatage conditionnel

Condition 1: SI($A5>JOURSDANSMOIS($D$1))
Condition 2: SI(OU(JOURSEM(DATE(ANNEE($D$1),MOIS($D$1),$A5))=1,JOURSEM(DATE(ANNEE($D$1),MOIS($D$1),$A5))=7))
Condition 3: NB.SI($Fériés.$A$2:$L$20,DATE(ANNEE($D$1),MOIS($D$1),$A5))

A5

Format: Entier numérique
Valeur: 1

B5, C5, D5 et E5

Format: Heure(HH:MM)
Valeur: -

F5

Format: Heure([HH]:MM)
Formule: =SI(OU(JOURSEM(DATE(ANNEE($D$1),MOIS($D$1),$A5))=1,JOURSEM(DATE(ANNEE($D$1),MOIS($D$1),$A5))=7,NB.SI($Fériés.$A$2:$L$20,DATE(ANNEE($D$1),MOIS($D$1),$A5))>0,$A5>JOURSDANSMOIS($D$1)),0,-$D$41)

G5

Format: Heure(HH:MM)
Formule: =SOMME((C5-B5)+(E5-D5))-F5

B36

Format: standard
Formule: =CONCATENER("Total heures ",TEXTE($D$1,"MMMM AAAA"))

G36

Format: Heure([HH]:MM)
Formule: =SOMME(G4:G35)

B37

Format: standard
Formule: =CONCATENER("./. Total des heures ",TEXTE($D$1,"MMMM AAAA")," dues")

G37

Format: Heure([HH]:MM)
Formule: =D43

B38

Format: standard
Formule: =CONCATENER("Solde ",TEXTE($D$1,"MMMM AAAA"))

G38

Format: Heure([HH]:MM)
Formule: =G36-G37

D41

Format: Heure(HH:MM)
Formule: =D42/C42

E41

Format: Heure (HH:MM)
Formule: =$Annuelle.$AJ$23

F41

Format: Heure (HH:MM)
Formule: =D41-E41

D42

Format: Heure ([HH]:MM)
Formule: =$Annuelle.$AG$24

E42

Format: Heure (HH:MM)
Formule: =C42*E41

F42

Format: Heure ([HH]:MM)
Formule: =D42-E42

C43

Format: Standard
Formule: =NB.JOURS.OUVRES($D$1,DATE(ANNEE($D$1),MOIS($D$1),JOURSDANSMOIS($D$1)),$Fériés.$A$2:$L$20)

D43

Format: Heure ([HH]:MM)
Formule: =C43*D41

E43

Format: Heure ([HH]:MM)
Formule: =C43*E41

F43

Format: Heure ([HH]:MM)
Formule: =D43-E43

Annuelle

AH6

Format: Standard
Formule: =F3+F4

AO6

Format: Standard
Formule: =F5

A8 - A19

Format: Date (MMM)
Formule: =DATE(ANNEE($F$2),LIGNE()-7,1)

B8

Formatage conditionnel

Condition 1 - fin_mois: SI(B$7>JOURSDANSMOIS($A8))
Condition 2 - weekends: SI(OU(JOURSEM(DATE(ANNEE($F$2),MOIS($A8),B$7))=1,JOURSEM(DATE(ANNEE($F$2),MOIS($A8),B$7))=7))
Condition 3 - vacances: NB.SI($Fériés.$A$2:$A$20,DATE(ANNEE($F$2),MOIS($A8),B$7))

AH8

Format: Standard
Formule: =NB.SI($B8:$AF8,AH$7)

AI8

Format: Standard
Formule: =NB.SI($B8:$AF8,AI$7)

AJ8

Format: Standard
Formule: =NB.SI($B8:$AF8,AJ$7)

AK8

Format: Standard
Formule: =NB.SI($B8:$AF8,AK$7)

AL8

Format: Standard
Formule: =NB.SI($B8:$AF8,AL$7)

AM8

Format: Standard
Formule: =NB.SI($B8:$AF8,AM$7)

AN8

Format: Standard
Formule: =SOMME(B8:AF8)

AO8

Format: Standard
Formule: =AN8-($AM8*$AG$23*60)

A20

Format: Standard
Formule: =CONCATENER("Date: ",TEXTE(AUJOURDHUI(),"DD MMMM YYYY"))

AH20

Format: Standard
Formule: =$AH$6-SOMME($AH$8:$AH$19)

AI20

Format: Standard
Formule: =SOMME($AI$8:$AI$19)

AJ20

Format: Standard
Formule: =SOMME($AJ$8:$AJ$19)

AK20

Format: Standard
Formule: =SOMME($AK$8:$AK$19)

AL20

Format: Standard
Formule: =SOMME($AL$8:$AL$19)

AM20

Format: Standard
Formule: =SOMME($AM$8:$AM$19)

AN20

Format: Standard
Formule: =SOMME($AN$8:$AN$19)

AO20

Format: Standard
Formule: =$AO$6+SOMME(AO$8:AO$19)

AG23

Format: Heure (HH:MM)
Formule: =AG24/AE24

AJ24

Format: Heure ([HH]:MM)
Formule: =AE24*AJ23

Fériés

A1 à L1

Format: Date (MMMM AA)
Formule: =DATE(ANNEE($Annuelle.$F$2);COLONNE();1)
1) made with LibreOffice 3.3.0
teaching/corrections13.txt · Last modified: 2012/11/26 15:55 by sbolay